Versions du SDK (P3DV4) complété par l'aide de P3D


#1

Bonjour à tous
Pour installer PRO ATC X sur un PC client j’ai, semble-t-il, besoin du SDK de ma version de P3D : 4.1.7.22841 et je ne l’avais pas téléchargé.
Le site de P3D ne me propose que le SDK Setup de la version 4.2.21.24048.
Le nouveau SDK est-il compatible avec ma version comme la proposition du site peut le laisser penser?
Sinon est-ce que quelqu’un peut me dire comment trouver le SDK ad hoc?
Je n’ai pas envie de prendre le risque de devoir réinstaller, j’ai pas mal d’addons et ça marche bien jusqu’à présent.
Dans le doute je préfère me tourner vers un logiciel d’ATC qui utiliserait un bridge maison ou WIDEFS7.
Je suis dans l’attente de conseils (éclairés, je n’en doute pas).
Merci
Jean

Après une analyse de texte de l’aide de P3D:

“The Prepar3D® v4 SDK is available as a free download to anyone looking to get into developing add-ons or content for Prepar3D® v4.
The Prepar3D v4 SDK 4.2.21.24048 is the current version and should be used to develop new content for Prepar3D v4. The SimConnect.lib and LockheedMartin.Prepar3D.SimConnect.dll provided in the SDK cannot be used to connect to FSX, ESP or any previous release of Prepar3D.”

Il semble qu’il ne soit pas possible de l’utiliser avec une version antérieure à P3DV4 et non à P3DV4.2.21.24048, mais je dis bien: il semble. Dans le doute, et quand on n’y connait pas grand chose, le doute est permanent, j’espère des avis compétents. Wait and see…


(Richard) #2

Pourquoi ça ne marcherait pas avec la SDK la plus récente ? Elles sont normalement rétro-compatibles. Ils ont mis 4.1.7.22841 parce qu’à l’époque c’était la version en cours.
Sinon pour télécharger la sdk précédente, tu prends le lien de la courante et tu changes avec le numéro de la précédente. En principe, LM n’efface pas les versions N-1 de leur cloud. J’ai réussi à la télécharger à l’instant, un vrai jeu d’enfant :slight_smile:


#3

Merci Richard

Effectivement c’était tout bête.

Par contre, je me suis un peu emballé sur WIDEFS7.
En effet, j’utilise FSUIPC5 qui fonctionne avec P3DV4, or, après relecture, il semble que WIDEFS7 qui est compatible avec FSUIPC5 ne le soit pas avec P3D.

Bonne journée à tous.

Jean


(system) #4

Ce sujet a été automatiquement fermé après 3 jours. Aucune réponse n’est permise dorénavant.