Tileproxy - Guide et support en français


#61

Bonjour Patrick,

Je viens de faire un essai avec Dataram_RAMDisk_v3.5.130R23. (Je suis toujours XP 32 bits)

Facile à configurer, j’ai donc créé un RAM disk de 768 MO sous la lettre K: puis je l’ai formaté NFTS.
Modification de mon proxyuser.ini pour changer le chemin de mes cache.service.
Lancement de TP avec Yahoo Maps (service3) puis de FSX.
Vérification : Le dossier cache.service3 s’est bien créé tout seul.
Vol d’une heure environ dans le fin fond de l’Idao

CA POUSSE TRES FORT. Belle augmentation de la vitesse de chargement des textures dans FSX.
Je me suis amusé a voler entre 150 et 200 Knts. Pas de problèmes.
Au bout d’une heure 1/4. Pause. j’ai été voir sur le RAM Disk K: ou en était le cache.service3 : environ 600 MO.
J’ai donc fait le ménage, suppression des sous-dossiers du cache.service3 et ensuite vidage du dossier RECYCLER.
Et je continue mon vol avec un RAM Disk presque vide.

Ce truc, c’est top et pas compliqué.

A + Pat


#62

Combien a tu de ram au total?

Je viens de regarder, ce soft est gratuit en plus, c’est cool :slight_smile:


#63

Bonsoir Gauthier,

J’ai 4 GB de RAM. J’ai essayé d’allouer 1 GB au RAM Disk puisque XP n’utilise que 3 GB.
Bon, ça marche pas, j’ai un message comme quoi j’aurais pas assez de RAM…
Je vais creuser un peu ça !
EDIT : Ca marche chez moi avec 1 GB de RAMDisk. La solution était de stopper RAMDisk puis de Rebooter le PC
et enfin seulement modifier la quantité de RAM allouée et de faire a nouveau start RAMdisk et de formater de nouveau en NFTS

En tout cas, merci à Patrick pour l’idée, parce qu’elle est vraiment bonne.
La solution est excellente pour ceux qui comme moi, ont une bonne connexion ADSL et
qui ne volent quasiment jamais au même endroit. D’ailleurs, Il y a longtemps que je ne fais plus
de conserve avec les “tiles”. Donc, Je formatais régulièrement la partition
ou j’ai mes cache.service pour faire le ménage.

A+ Pat


#64

Bonjour à tous,

Content d’avoir apporter ma contribution à ce forum et, peut-être, d’avoir donner une solution (gratuite) de booster le duo FSX/TP.
Mais, justement à ce propos je voudrais apporter qqs précisions:

  • En dehors de booster considérablement TP, un RamDisk ne sert à pas grand chose sur un PC normalement utilisé. Le fait d’utiliser cette manip comme cache pour les navigateurs, comme le suggère Christophe, ChD ne sert pas vraiment à grand chose surtout que Firefox permet déjà en natif de paramètrer tout ou partie de son cache dans la Ram directement sans passer par un soft quelconque
    Si on a beaucoup de Ram, en utiliser une partie en RamDisk peut être utile si on fait du montage vidéo, de la retouche photo ou si on utilise des programmes de création musicale. En dehors de ça…!
  • Un RamDisk permettra de booster TP si le boost est possible: si le proc est limite, si la connexion internet est basse (<2Mb/sec), le boost ne sera même pas visible.
    Je dis ça juste pour éviter que tout le monde se précipite pour acheter de la Ram et soit déçu des résultats.
    Pour ma part, j’ai trouvé cette astuce car je voulais booster TP et la seule solution que je connaissais était la SDD mais comme je n’ai plus de prise Sata de dispo sur ma CM: j’ai déjà 5 DD, 2 lecteurs/graveurs DVD et une prise Sata externe mais 12 Go de Ram et je sais ne même pas en utiliser la moitié, je me suis souvenu d’une vieille manip sous Win95 pour utiliser la ram en RamDisk, j’ai cherché et trouvé. Voilà comment j’en suis arrivé au RamDisk mais, ce qui est valable pour moi ne l’est pas nécessairement pour d’autres.

#65

Tout ça est bien beau , mais le coeur du problème avec Tp , c’est … la connexion internet . Tout repose là dessus .
Sans une excellente connexion performante , il ne faut pas se faire d’illusions .

par exemple , ce soir d’élection présidentielle , un dimanche qui plus est , et étant en WiFi ce qui n’arrange rien ,

j’ai un débit de … 0,51 Mbits/s

inutile d’essayer voler avec TP ce soir , Ramdisk ou pas …

:unamused:


#66

Tu as bien raison Redcloud, c’est exactement ce que je disais dans le post posté qqs heures avant le tien:
"Un RamDisk permettra de booster TP si le boost est possible: si le proc est limite, si la connexion internet est basse (<2Mb/sec), le boost ne sera même pas visible."
C’est sympa de confirmer mes propos!

Patrick


#67

Je suis un vieil utilisateur de Tp , depuis ses débuts , et je connais ses limites .


#68

Bonjour à tous

Je viens de découvrir tile proxy :blush: , du moins en théorie :confused:
J’ai suivi le super tuto de patgarret, j’ai tout fait pas à pas, mais évidemment si je suis là, c’est que c’était trop beau, trop facile…

Mon problème est que j’ai bien les deux dossiers sur un autre disque: cache.service1 et TileProxy Photoreal World qui se remplissent sans problème de dossiers avec les photos à l’intérieur … mais apparemment il n’y a pas de connection avec fsx, car j’ai toujours les textures d’fsx.
Je lance bien en premier tile proxy, j’ai même attendu une bonne dizaines de minutes, au cas, pour le premier lancement, c’est peut être plus long. J’ai bien configuré le pare feu par rapport à fsx et tile proxy, je l’ai même désactivé au cas où.
J’ai eu beau réinstaller deux fois, c’est pareil … là je sèche.

Merci par avance pour vos réponses

zen_=)


#69

Bonsoir Laurent,

Ce que tu dis est un peu flou: Je lance bien en premier tile proxy, j’ai même attendu une bonne dizaines de minutes, au cas, pour le premier lancement, c’est peut être plus long car quand tu lances TP une fenêtre de lignes de cmd s’ouvre et en bas de cette fenêtre, si tout est OK tu peux lire: Tileproxy ready to take off. Là tu lances FSX et dans la fenêtre cmd des formes ovales apparaissent qui vont se remplir de croix, ça veut dire que tout va bien et que les tuiles se chargent. Tu prépares ton vol: avion, heure, méteo et aéroport et tu lances par O K. Et là, ça peut durer longtemps (5, 10 mn) avant que FSX soit prêt à de laisser voler.
D’après ce que tu dis, les tuiles se chargent sur ton DD mais, ne sont pas accessibles à FSX, difficile à comprendre! As-tu desactivé ton antivirus (et pas seulement le firewall)? Es tu sûr d’avoir le “ready to take off” dans la fenêtre TP?
L’outil qui permet à TP de communiquer avec FSX est Simconnect qui est un outil Microsoft et qui est partie intégrante de TP quand tu le télécharges donc, il n’y a pas de raison qu’il ne soit pas là. A tout hasard vérifies que tu as bien un fichier Simconnect.msi dans le dossier Tileproxy dans FSX.

Tiens nous au courant.

A+
Patrick


#70

[quote=“patmiche”]Bonsoir Laurent,

Tu lances TP une fenêtre de lignes de cmd s’ouvre et en bas de cette fenêtre, si tout est OK tu peux lire: Tileproxy ready to take off. Là tu lances FSX et dans la fenêtre cmd des formes ovales apparaissent qui vont se remplir de croix, ça veut dire que tout va bien et que les tuiles se chargent. Tu prépares ton vol: avion, heure, méteo et aéroport et tu lances par O K. Et là, ça peut durer longtemps (5, 10 mn) avant que FSX soit prêt à de laisser voler.[/quote]
Jusque là on est 5/5

[quote=“patmiche”]
D’après ce que tu dis, les tuiles se chargent sur ton DD mais, ne sont pas accessibles à FSX, difficile à comprendre! As-tu desactivé ton antivirus [/quote]
Non, j’ai pas osé, il y a un risque de chopper un virus, si c’est pour se retaper un formatage aprés, c’est un peu chaud , non? Je ne vois pas pourquoi l’antivirus empêcherai un dossier accéder à fsx?

Vous avez tous enlevé votre antivirus? Il n’y a aucun souci? Parce que dans ces cas là, pourquoi garder un antivirus?


#71

Bon, je viens d’essayer sans antivirus, ben c’est pareil, ça ne marche pas :confused:


#72

hello

et tu as bien déclaré tes scènes comme suit ?

7.3.1) Dans PARAMETRES > Bibliothèque de décors : Vérifiez que toutes les entrées de Tileproxy sont bien au dessus de celles de vos autres Add’ons, et que WORLD_LOD8 est bien placé en dessous de toutes les 99 lignes des WORLD_…

WORLD_1107

WORLD_1106

……
……

WORLD_0001

WORLD_0000

WORLD_LOD8

cf : tileproxy.eklablog.com/


#73

Oui je confirme tout est bien déclaré dans la bibliothèque comme tu l’écris, j’ai suivi pas à pas ce tuto:
tileproxy.eklablog.com/
C’est pour ça je ne sais plus quoi faire. FSX ne reçoit pas l’info, j’essayerai demain sur le même disque pour voir…


#74

Bonsoir Laurent,

Là, tu me pose une colle… Si tu as suivi mon tutoriel a la lettre, ça DOIT fonctionner !
Depuis sa publication, j’ai plus de question de ce genre !!!

Réfléchissons :

  1. Tout d’abord en désactivant l’antivirus avec Tileproxy, tu ne risque strictement aucun problème sauf a oublier de le réactiver un fois ton vol fini.

  2. Seule explication : FSX ne semble pas trouver "Tileproxy Photoreal World"
    Alors… est-ce que tous tes WORLD_… depuis WORLD_1107 et jusqu’à WORLD_LOD8 tout a la fin
    sont ils bien réellement situés au début de ta bibliothèque de décors ?

Poste moi moi ton proxyuser.ini et plus de détails sur ta configuration disque, en particulier, ou tu as déclaré les dossiers TP à l’installation:

A+ Patrice


#75

Je suis profondément désolé mon pauvre Patrice :blush: , car tu as fait un tutorial d’une trés grande clarté et d’une trés grande simplicité bravo_)=

Là je viens d’installer sur le même disque que FSX, ben non, toujours rien, pourtant j’ai bien les photos dans les dossiers de cache service1

[TileProxy]

master_enable=On

diskless_mode=Off

offline_mode=No

max_lod=15

preload_min_lod=9

preload_max_lod=15

max_contexts=512

water_mask=On

water_blending=On

blend_distance=500.0

blend_exponent=1.0

alpha_min=0.2678

alpha_max=0.7

water_rgb=#407B80

water_smoothing=Off

water_threshold=0.33

cache_bytes_limit=100000000

cache_tiles_limit=100000

source=Virtual Earth

#source=Webatlas

#source=Yahoo Maps

menu_sources=“Virtual Earth|Webatlas|Yahoo Maps”

enable_hooking=No

enable_dx9hook=No

enable_movingmap=No

movingmap_alpha=255

movingmap_color=#ff000000

movingmap_xpos=88

movingmap_ypos=15

movingmap_width=60

movingmap_height=80

movingmap_radius=60

[Virtual Earth]

cache_folder=C:\Program Files\Microsoft Games\cache.service1

network_module=libnettile

module_config=“conn=20|rate=2.0|verbose=0|server=http://a*.ortho.tiles.virtualearth.net|path=/tiles/a%s.jpeg?g=%v|quad=0123|balance=0123|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)”

min_level=10

max_level=17

map_version=854

level_mapping=10,11,12,14,14,15,16,17

color_hack=Yes

color_level=13

bulk_extend=25

[Webatlas]

cache_folder=C:\Program Files\Microsoft Games\cache.service2

network_module=libnettile

module_config=“conn=20|rate=2.0|verbose=0|server=http://ts1*.webatlas.no|path=/qt_1881/%s.png?s=%v|quad=0123|balance=0123456|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)”

min_level=10

max_level=17

map_version=1

level_mapping=10,11,12,14,14,15,16,17

color_hack=Yes

color_level=13

bulk_extend=25

[Yahoo Maps]

cache_folder=C:\Program Files\Microsoft Games\cache.service3

network_module=libnettile

module_config=“conn=20|rate=2.0|verbose=0|server=http://us.maps3.yimg.com|path=/aerial.maps.yimg.com/img?x=%x&y=%y&z=%z&v=%v&t=a|useragent=Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; .NET CLR 1.1.4322)”

min_level=10

max_level=17

level_mapping=10,11,12,14,14,15,16,17

map_version=1.9

color_hack=No

color_level=0

bulk_extend=25

Sur les autres essais, les dossiers se situaient sur F et ils avaient les photos qui allaient bien, mais ça va pas dans FSX


#76

:smiley: :smiley: :smiley: Le “pauvre” Patrice rigole… Celui qui est dans la mouise c’est le “pôvre” Laurent !

Bon… Au vu de ta capture d’écran… Le problème peut venir du fait que FSX ne trouve pas ses 'tiles" dans le dossier “Tileproxy Photoreal World”… Ou est il ? Ou l’as tu mis à l’installation ? sur quel disque /partition ? Est-ce qu’il existe et est-ce qu’il y a quelque chose dans ce dossier ???

J’aimerai avoir aussi une copie d"écran de la fenêtre DOS de Tileproxy au démarrage, comme celle là :

Autre question : J’ai l’impression que tu charges que dalle… dans ton cache.service1… Problème de pare-feu ? Quel antivirus utilise tu ? Certains posent de réels soucis même quand soit-disant désactivés (c’est le cas avec Avast). Le seul que je recommande c’est Avira Free Antivirus (Pub gratuite pour un antivirus gratuit et efficace qui ne gêne pas TP une fois la protection “temps réel” désactivée)

Conclusion : Tu DOIS y arriver fum_)= fum_)= fum_)=

A+ Pat

PS : Va mettre a jour la map_version du service1 : map_version=918


#77

Je confirme, c’est bien moi le pôôôôvee titi hel)= rigo(-

En te lisant, une ampoule, que dis je un phare d’atterrissage, un phare de haute mer, ouais, s’allume dans mon cerveau,je te cite

[quote=“Pat ‘Grizzly’ Garret”]

Quel antivirus utilise tu ? Certains posent de réels soucis même quand soit-disant désactivés (c’est le cas avec Avast).[/quote]

D’aprés toi quel antivirus j’utilise??? sfl:

Ben ouais Avast, c’est vrai que des fois dans le passée, il m’interdisait certains éxécutables qui n’était absolument pas vérolés…
Et Avira Free est bien, tu n’as jamais eu de problème de virus?

Tant que j’y suis je t’envoie le DOS

Bon je verrai ça se soir, grand merci et bonne journée


#78

Salut Laurent,

J’utilise Avira depuis longtemps, c’est un bon antivirus. Efficace et léger. Une fois par semaine, je lance Malewarebyte en complément. Jamais eu de pépins !

Ce qui m’a mis la puce à l’oreille, c’est que j’ai voulu tester il y a deux semaines la dernière version d’Avast… Résultat Tileproxy ne fonctionnait plus !!! Aussitôt désinstallé ! J’ai réinstallé Avira et TP roule comme avant, c’est à dire très bien.

Fais comme moi et essaye de nouveau car le contenu de ta fenêtre DOS me parait correct.
Bien sur, évite de mettre Tileproxy Photoreal World et tes cache.service sur C:
Désinstalle TP et réinstalle ces dossiers sur un autre disque ou au moins sur une autre partition.

A+ Patrice


#79

Whooooooooohhouuuuuuuuuuu, c’est énooooooooorme, ça marche … crie=) Adios Avast

Nickel, encore merci à tous zen_=)


#80

Et quand tu le désactivais juste ça ne fonctionnait pas?

Il restait donc un minimum actif le bougre :smiley: