Scene fsx compatible avec p3D V4


#1

Bonsoir tout le monde,
Voulant savoir si mes scènes africaines faites pour fsx étaient compatibles avec P3D V4, je les ai donc transférées et à mon grand plaisir, ça fonctionne !
Sauf les taxiways dont on voit les lignes mais pas le revêtement.
J’ai donc repris l’afcad avec AED pour le recompiler avec les outils de P3D.
Malheureusement le résultat est le même !
J’ai essayé en changeant la texture ( au lieu de concrète, j’ai mis asphalte mais le résultat est identique
Je suis assez surpris, car les polygones qui ont le même revêtement sont parfaitement visibles.
Auriez-vous une piste pour remédier à ce problème ?
Merci de d’éclairer ma lanterne.
Bonne soirée à tous
:grinning:


#2

J’ai déjà rencontré ce problème avec des scènes peut-être un peu vieilles (les bgl étaient des ADE, pas des ADEX, ADEP3 ou ADEP4)
Avec ADE, tu as utilisé le bglcomp du SDK P3D v4?
Essaie peut-être avec le compilateur du SDK de P3D v3, ou FSX, juste pour voir?
J’ai vu sur le forum de SOH que certains éléments, comme les taxiways et runways entre autres, présentaient de toutes petites différences en v4 qu’avant (N° d’ID, ou structure du fichier, un truc du genre).
Les aéroports de base ne sont pas touchés, car je pense qu’ils n’ont pas été recompilés depuis quelques versions, mais les aéroports travaillés avec ADE peuvent être impactés par ces petites différences dûes au compilateur LM.
Blue skies


(Richard) #3

Avec la V4, certains paramètres doivent être cochés sinon la compilation n’en tient pas compte et donne un élément manquant comme le taxyway. Ces paramètres existaient sous FSX et P3Dv3 mais n’étaient pas utilisés car Ace n’avait pas prévu de laisser tout en plant comme ça quand MS a fermé le studio.
Pour plus d’infos, voir ici:
https://scruffyduck.screenstepslive.com/s/help_docs/m/20268/l/199756-how-do-i-set-taxi-link-draw-flags-to-default-values

C’est en anglais mais c’est pas la mer à boire


#4

Bonjour,
Merci pour le lien, Problème résolu.
S’il y en a parmi vous qui possèdent Dakar pour FSX fait par mes soins, je peux vous faire parvenir le nouvel afcad qui fonctionne sur P3D V4
Cordialement
:grinning:


#5

@Wildweasel
Merci pour le lien. Je me le garde sous le coude!
Blue skies


#6

Bonjour,
Bonne nouvelle !
Toutes les scènes pour FSX que j’avais concocté fonctionnent parfaitement sous p3D V4.
Seuls les afcads demadent une mise à jour.
Pour mémoire il s’agit de DAKAR (GOOY) Ziguinchor(GOGG) et Saint Louis du Sénégal (GOSS).
Comme les afcads sont des petits fichiers je peux les envoyer par mail (me donner votre mail en mp).
Je suis bien content.
Si mon GMAX veut bien fonctionner, je tenterai de refaire les animations que j’avais faite pour les version FS2009 avec CAT et les faire pour SODE.
Bonne journée à tous